Project

General

Profile

Bug(バグ) #1905

OpenPNE3.4 から3.6へのバージョンアップ後の /member で intro_friend doesn't exist のエラーが発生するl

Added by takahiro yoshino over 9 years ago. Updated over 9 years ago.

Status:
Works for me(再現せず)
Priority:
Normal(通常)
Start date:
2011-02-03
Due date:
% Done:

0%

3.6 で発生するか:
Yes
[QA]バグ通知済:
No
3.8 で発生するか:
Unknown (未調査)

Description

OpenPNE-3.4.9.2aからOpenPNE-3.6beta8bにソースコードを更新し、
OpenPNE3_Version_Up_Guide.txt を参考にアップデート実施(実際の手順は下記参照)した後で
http://$URL/member/$memberid にアクセスすると以下のエラーが発生します。

http://sns.example.com/pc_frontend_dev.php/member/1

  500 | Internal Server Error | Doctrine_Connection_Mysql_Exception
  SQLSTATE[42S02]: Base table or view not found: 1146 Table 'sns_example_com.intro_friend' doesn't exist

データベース上では intro_friend テーブルは存在しているようです(ただし、中身は空)

  $ mysql -u root -p 
  > show tables
  | intro_friend                      |
  mysql> select * from intro_friend;
  Empty set (0.00 sec)

■参考:バージョンアップ手順

  $ ./symfony doctrine:build-model
  $ ./symfony cc

  // DB設定の変更
  // opFavoritePlugin_needs_data_loadと opIntroFriendPlugin_needs_data_load の2つの値を1に設定する必要がある  
  // https://gyoen.pne.jp/redmine/issues/1428#note-2
  $ mysql -u root -p sns_example_com
  > update sns_config set value = 1 where id = 39;
  > update sns_config set value = 1 where id = 38;

  // DBのマイグレーション
  $ ./symfony openpne:migrate
  >> plugin    installing plugin "opIntroFriendPlugin" 
  >> sfPearFrontendPlugin downloading opIntroFriendPlugin-0.9.1.2.tgz ...
  >> sfPearFrontendPlugin Starting to download opIntroFriendPlugin-0.9.1.2.tgz (13,153
  >> sfPearFrontendPlugin bytes)
  >> sfPearFrontendPlugin ...done: 13,153 bytes
  >> sfPearFrontendPlugin downloading symfony-1.4.8.tgz ...
  >> sfPearFrontendPlugin Starting to download symfony-1.4.8.tgz (3,177,818 bytes)
  >> sfPearFrontendPlugin .
  >> sfPearFrontendPlugin ...done: 3,177,818 bytes
  >> opPluginManager Installation successful for plugin "opIntroFriendPlugin" 
  >> plugin    installing plugin "opFavoritePlugin" 
  >> sfPearFrontendPlugin downloading opFavoritePlugin-1.0.0.3.tgz ...
  >> sfPearFrontendPlugin Starting to download opFavoritePlugin-1.0.0.3.tgz (10,961
  >> sfPearFrontendPlugin bytes)
  >> sfPearFrontendPlugin ...done: 10,961 bytes
  >> opPluginManager Installation successful for plugin "opFavoritePlugin" 
  >> plugin    installing plugin "opRankingPlugin" 
  >> sfPearFrontendPlugin downloading opRankingPlugin-1.0.0.tgz ...
  >> sfPearFrontendPlugin Starting to download opRankingPlugin-1.0.0.tgz (7,930 bytes)
  >> sfPearFrontendPlugin ...done: 7,930 bytes
  >> opPluginManager Installation successful for plugin "opRankingPlugin" 
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> opPluginManager Installing web data for plugin
  >> doctrine  generating model classes
  >> file+     /tmp/doctrine_schema_19760.yml
  セグメンテーション違反です 
  // cache以下を削除して再実行
  $ rm -rf cache/*
  $ ./symfony openpne:migrate
  //↑問題なく終了

  $ ./symfony plugin:publish-assets

History

#1 Updated by Kiwa Sakai over 9 years ago

  • Assignee changed from Kiwa Sakai to Masato Nagasawa

おねがいします

#2 Updated by Masato Nagasawa over 9 years ago

  • Status changed from New(新規) to Works for me(再現せず)

再現できませんでした。
恐らく手順か環境に問題があるものと思われます。

Also available in: Atom PDF