Project

General

Profile

Bug(バグ) #274

3.1.2から3.1.5へのアップグレードでエラーが出る

Added by pnetan   over 11 years ago. Updated over 3 years ago.

Status:
Won't fix(対応せず)
Priority:
Normal(通常)
Assignee:
-
Target version:
-
Start date:
2009-11-26
Due date:
% Done:

0%

3.6 で発生するか:
No
3.8 で発生するか:
Unknown (未調査)

Description

http://sns.openpne.jp/?m=pc&a=page_c_topic_detail&target_c_commu_topic_id=5112 より転記

はじめまして。お世話になります。
現在OpenPNE3.1.2でSNSを運用中で、リリースされた3.1.5にアップグレードしようとしたのですが、エラーが出てしまいます。

アップグレードは、下記『OpenPNE 3.1 バージョンアップガイド』の通りの手順で行いました。
3.1.1から3.1.2へのバージョンアップは、同じページを参照して問題なく行えました。
http://www.openpne.jp/openpne_3_1_update_guide/

【エラー文】

SQLSTATE[HY000]: General error: 1005 Can't create table 'openpne3.#sql-453a_b658' (errno: 121). Failing Query: ALTER TABLE deleted_message ADD CONSTRAINT deleted_message_member_id_member_id FOREIGN KEY (member_id) REFERENCES member(id) ON DELETE CASCADE

【環境】

CentOS 5.3+Apache 2.2+PHP 5.3.0+MySQL 5.1.37です。

原因・対処法をご存知の方がいらっしゃいましたら、お知恵を貸してください!
よろしくお願いいたします。 

History

#1 Updated by Kousuke Ebihara almost 11 years ago

  • 3.6 で発生するか set to No

#2 Updated by Chiharu Nakajima over 3 years ago

  • Status changed from New(新規) to Won't fix(対応せず)

サポートが終了しているバージョンであるため、対応せず

Also available in: Atom PDF