Project

General

Profile

Bug(バグ) #3524

openpne:install 時に Segmentation fault が発生する

Added by Yuya Watanabe almost 9 years ago. Updated almost 3 years ago.

Status:
New(新規)
Priority:
Low(低め)
Assignee:
-
Target version:
Start date:
2013-12-11
Due date:
% Done:

0%

3.6 で発生するか:
Unknown (未調査)
3.8 で発生するか:
Unknown (未調査)

Description

概要

openpne:install 時に Segmentation fault が発生する.
具体的な再現方法は不明なため,類似した問題があった場合のヒントとしてとりあえずチケットを切っておきます.

>> doctrine  Dropping "doctrine" database
>> doctrine  Creating "prod" environment "doctrine" database
>> doctrine  generating model classes
>> file+     /tmp/doctrine_schema_75279.yml

Program received signal SIGSEGV, Segmentation fault.
0x00000000006a12c4 in zend_get_class_entry (zobject=0x37fa210) at /tmp/buildd/php5-5.4.4/Zend/zend_API.c:237
237     /tmp/buildd/php5-5.4.4/Zend/zend_API.c: No such file or directory.
(gdb) bt 
#0  0x00000000006a12c4 in zend_get_class_entry (zobject=0x37fa210) at /tmp/buildd/php5-5.4.4/Zend/zend_API.c:237
#1  0x00000000006b62fa in zend_call_method (object_pp=0x37fa1d8, obj_ce=0x0, fn_proxy=0x37fa1d0, function_name=0x0, 
    function_name_len=58264064, retval_ptr_ptr=0x7fffffffafb8, param_count=5840295, arg1=0x1, arg2=0x17b21b0)
    at /tmp/buildd/php5-5.4.4/Zend/zend_interfaces.c:68
#2  0x0000000000591da7 in zif_spl_autoload_call (ht=58696208, return_value=0x0, return_value_ptr=0x37fa1d0, this_ptr=0x0, 
    return_value_used=58264064) at /tmp/buildd/php5-5.4.4/ext/spl/php_spl.c:436
#3  0x0000000000691f8d in zend_call_function (fci=0x7fffffffb270, fci_cache=0x0) at /tmp/buildd/php5-5.4.4/Zend/zend_execute_API.c:980
#4  0x000000000069288b in zend_lookup_class_ex (name=0x37067d0 "Doctrine_Template_opCommunityTopicPluginImagesBehavior", name_length=54, 
    key=0x0, use_autoload=24846768, ce=0x7fffffffb320) at /tmp/buildd/php5-5.4.4/Zend/zend_execute_API.c:1127
#5  0x00000000006b1880 in zif_class_exists (ht=58696208, return_value=0x355b820, return_value_ptr=0x37fa1d0, this_ptr=0x0, 
    return_value_used=58264064) at /tmp/buildd/php5-5.4.4/Zend/zend_builtin_functions.c:1233
#6  0x00000000007470b2 in zend_do_fcall_common_helper_SPEC (execute_data=0x7ffff7e55608)
    at /tmp/buildd/php5-5.4.4/Zend/zend_vm_execute.h:642
#7  0x0000000000700927 in execute (op_array=0x23144c0) at /tmp/buildd/php5-5.4.4/Zend/zend_vm_execute.h:410
#8  0x00000000006a076e in zend_execute_scripts (type=8, retval=0x7ffff7e76630, file_count=3) at /tmp/buildd/php5-5.4.4/Zend/zend.c:1279
#9  0x000000000063fc93 in php_execute_script (primary_file=0x3662e) at /tmp/buildd/php5-5.4.4/main/main.c:2473
#10 0x0000000000749693 in do_cli (argc=0, argv=0x7fffffffeec6) at /tmp/buildd/php5-5.4.4/sapi/cli/php_cli.c:988
#11 0x00000000004312aa in main (argc=32767, argv=0xdba210) at /tmp/buildd/php5-5.4.4/sapi/cli/php_cli.c:1361

環境

  • OpenPNE 3.6.12
  • Debian 7
  • PHP 5.4.4
$ cat /etc/issue
Debian GNU/Linux 7 \n \l
$ php -v
PHP 5.4.4-14+deb7u5 (cli) (built: Oct  3 2013 09:24:58) 
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
$ php symfony openpne:version
Core versions:
 OpenPNE                       3.6.12
 symfony                       1.4.13
OpenPNE plugin versions:
 opAlbumPlugin                 0.9.4.1
 opCommunityTopicPlugin        1.0.5
 opSkinClassicPlugin           unknown
 opIntroFriendPlugin           1.0.0
 opAuthOpenIDPlugin            1.3.1
 opAshiatoPlugin               1.1.1
 opWebAPIPlugin                0.5.1.1
 opSkinBasicPlugin             unknown
 opAuthMobileUIDPlugin         1.3.3
 opDiaryPlugin                 1.4.1
 opRankingPlugin               1.0.1
 opBlogPlugin                  1.0.1
 opOpenSocialPlugin            1.2.6.1
 opMessagePlugin               1.0.0
 opFavoritePlugin              1.0.1
 opAuthMailAddressPlugin       1.3.5

History

#1 Updated by Yuya Watanabe almost 9 years ago

  • Description updated (diff)

#2 Updated by Yuya Watanabe almost 9 years ago

  • Description updated (diff)

#3 Updated by Chiharu Nakajima almost 8 years ago

  • Priority changed from Normal(通常) to Low(低め)

#4 Updated by Chiharu Nakajima almost 8 years ago

このチケットの内容は下記の項目に該当する不具合であるため、一旦優先度を下げます。
・一部の特殊なサーバー環境のみで発生する不具合

#5 Updated by kaoru n almost 3 years ago

  • Target version set to OpenPNE 3.10.x

Also available in: Atom PDF