Project

General

Profile

Enhancement(機能追加・改善) #3957

PHP5.6向けにAPCu拡張のインストールを推奨する記述を追加する

Added by Youichi Kimura about 3 years ago. Updated over 2 years ago.

Status:
Won't fix(対応せず)
Priority:
Normal(通常)
Target version:
Start date:
2016-06-14
Due date:
% Done:

0%


Description

Overview (概要)

#3919-8 で調査したとおり、PHP 5.6 以降で APC が使用できない件について OpenPNE 内で APC の関数を使用している箇所については APCu をインストールすることで代替が可能なため、OpenPNE のインストール手順に APUu 拡張モジュールのインストールを推奨する旨を記載する。

Spec (仕様)

現行のインストール手順には「PHP の APC 拡張モジュールの使用を推奨」と記載されている所を「PHP の APC (または APCu) 拡張モジュールの使用を推奨」に書き換える。

APCu 拡張モジュールの推奨については特に PHP 5.6 以降の場合に限定しません。
これは APCu 自体が PHP 5.3.0 以降で動作することと、PHP 5.3 の頃から APC は同梱されておらず opcode cache 部分に関しては php_opcache に置き換わっているためです。


Related issues

Copied to OpenPNE 3 - Backport(バックポート) #3974: PHP5.6向けにAPCu拡張のインストールを推奨する記述を追加する Fixed(完了) 2016-06-14
Copied to OpenPNE 3 - Backport(バックポート) #3975: PHP5.6向けにAPCu拡張のインストールを推奨する記述を追加する Fixed(完了) 2016-06-14

History

#1 Updated by Youichi Kimura about 3 years ago

  • Status changed from New(新規) to Pending Review(レビュー待ち)
  • Assignee set to Youichi Kimura
  • % Done changed from 0 to 50

下記 Pull Request にて追加しました
https://github.com/openpne/OpenPNE3/pull/337

#2 Updated by Youichi Kimura about 3 years ago

  • Status changed from Pending Review(レビュー待ち) to Fixed(完了)
  • % Done changed from 50 to 100

#3 Updated by Youichi Kimura about 3 years ago

  • Status changed from Fixed(完了) to Pending Review(レビュー待ち)
  • % Done changed from 100 to 50

再度 Pull Request を作成しました。
https://github.com/openpne/OpenPNE3/pull/338

#4 Updated by Chiharu Nakajima about 3 years ago

#5 Updated by Chiharu Nakajima about 3 years ago

#6 Updated by kaoru n about 3 years ago

レビューします

#7 Updated by kaoru n about 3 years ago

  • Status changed from Pending Review(レビュー待ち) to Pending Merge(マージ待ち)
  • % Done changed from 50 to 80

みました
テスト不要のため、マージ待ちにします

#8 Updated by kaoru n over 2 years ago

  • Status changed from Pending Merge(マージ待ち) to Won't fix(対応せず)
  • Target version changed from OpenPNE 3.9.0-old to OpenPNE 3.9.0
  • % Done changed from 80 to 0

OpenPNE 3.8.21 にて対応済みであったため、対応せずとします。

Also available in: Atom PDF