Project

General

Profile

Backport(バックポート) #4037

PHP_CodeSniffer 最新版で動作するようにする

Added by isao sano over 3 years ago. Updated over 3 years ago.

Status:
Won't fix(対応せず)
Priority:
Normal(通常)
Assignee:
Target version:
Start date:
2016-11-14
Due date:
% Done:

0%


Description

Overview (概要)

現在 OpenPNE3 の data/CodingStandard/OpenPNE3 以下にあるファイルは PHP_CodeSniffer 1.2.x でないと動作しない。
PHP_CodeSniffer 最新版で動作するようにする

Spec (仕様)

PHP_CodeSniffer 最新版で動作するようにする


Related issues

Related to OpenPNE 3 - Enhancement(機能追加・改善) #4004: PHP_CodeSniffer 最新版で動作するようにする Rejected(差し戻し) 2016-09-02

History

#1 Updated by isao sano over 3 years ago

#2 Updated by Youichi Kimura over 3 years ago

  • Status changed from New(新規) to Won't fix(対応せず)

バックポート元の #4004 は PHP_CodeSniffer 2.7 へのアップデートに対応するための非互換な修正を含んでいるため、安定版への反映は適さないと判断して閉じます。

一方で関連する #4003 は、stable-3.6.x ブランチに入っているが stable-3.8.x には入っていなかったコミット 6ca5dcd8 を取り込むためのバックポートチケットであり PHP_CodeSniffer のバージョンは依然として 1.2.x を対象としているため引き続き安定版への反映を行います。

参照: #2503-13

Also available in: Atom PDF