Project

General

Profile

Backport(バックポート) #4416

Task(タスク) #4071: OpenPNEに同梱されている TinyMCE 3.4.4 が IE11 に対応していないため、バージョンアップについて調査する

OpenPNEに同梱されている TinyMCE 3.4.4 が IE11 に対応していないため、バージョンアップについて調査する

Added by isao sano 5 months ago. Updated 2 months ago.

Status:
New(新規)
Priority:
High(高め)
Assignee:
Target version:
Start date:
2016-12-20
Due date:
% Done:

0%


Description

Overview (概要)

OpenPNE がリッチテキストエディタとして採用している TinyMCE のバージョンが古く IE11 で正常に動作しないため、バージョンアップについて調査を行う。

正常に動作しない例
・プレビューモードが動作しない
・<meta http-equiv="X-UA-Compatible" content="IE=10"> を追加した場合、下記のような不自然な動作となる
1. プレビューモード を選択
2. 1行目に適当な文字を入力し、行末でEnterキーを押下するが、改行されずカーソルが行末に残る
3. 再度Enterキーを押下すると改行され、2行目の行頭にカーソルが移動する
4. 文字を入力すると、カーソルが3行目に移動し3行目行頭に文字が入力される

OpenPNE に同梱されている TinyMCE のバージョンは、3.4.4 であるが、TinyMCE 3.x は IE11 に対応していない。
http://archive.tinymce.com/wiki.php/TinyMCE3x:Browser_compatiblity
IE11 に対応している TinyMCE のバージョンは、4.x となる。
https://www.tinymce.com/docs/get-started/system-requirements/

TinyMCE3.x の最新版は 3.5.12(2016/10/31)
https://github.com/tinymce/tinymce/releases/tag/3.5.12
TinyMCE4.x の最新版は、4.5.1(2016/12/07)
https://github.com/tinymce/tinymce/releases/tag/4.5.1

OpenPNE としては、IE11 に対応する必要があるので、TinyMCE をバージョンアップする場合は、4.x にバージョンアップする必要がある。
また、OpenPNE では、同梱の TinyMCE に対して独自のカスタマイズを行っているため、このカスタマイズについても影響などの調査が必要。
#2362 にて、TinyMCE 3.2.7 から 3.4.4 へのバージョンアップが行われているので参考にする。

また、TinyMCE 以外のライブラリへ変更する案も同時に検討したい。


Related issues

Copied to OpenPNE 3 - Backport(バックポート) #4417: OpenPNEに同梱されている TinyMCE 3.4.4 が IE11 に対応していないため、バージョンアップについて調査する New(新規) 2016-12-20

History

#1 Updated by isao sano 5 months ago

  • Copied to Backport(バックポート) #4417: OpenPNEに同梱されている TinyMCE 3.4.4 が IE11 に対応していないため、バージョンアップについて調査する added

#2 Updated by kaoru n 2 months ago

  • Target version changed from OpenPNE 3.10.1 to OpenPNE 3.10.x

Also available in: Atom PDF