Project

General

Profile

Bug(バグ) #726

google mapが正常に表示されなくなった。

Added by pnetan   about 11 years ago. Updated over 1 year ago.

Status:
New(新規)
Priority:
Normal(通常)
Assignee:
-
Target version:
Start date:
2010-02-22
Due date:
% Done:

0%

3.6 で発生するか:
No (いいえ)
3.8 で発生するか:
No (いいえ)

Description

http://sns.openpne.jp/?m=pc&a=page_fh_diary&target_c_diary_id=23673 より転載

google様の怒りに触れたのか、なぜかmap表示が昨日は出来たのですが
今日は出来なくなりました。
現状ではただのリンクになっちゃいました。

昨日書き込んだ地図は今日も正常に表示はされているのですが
Keyを取得後に、特にgoogle様から確認のメールも来なくてすぐに
使えたのですが・・・・何が不味かったのか今のところ検討が付かないでいます。

環境はCentOS5.4で標準で入ってるapacheを使用しています。
その上でバーチャルドメインを使用し、同じサーバ内で実験用と
本番用の2箇所を設定しました。

実験で表示されたので、本番用のkeyも取得して登録し念のため
試してすぐに消してしまいました。

実験用に残っている表示されてる地図は、流石にKey無しにすると枠だけで
何も表示されない上にkeyを要求する窓が出て、怒られますね←アタリマエカ・・・

ためしにソースを新たに別な場所に入れて、新たに設定してみましたが
結果はおなじでした。
その際使用したドメインとkeyは同じものです。
もう暫くしたらDDNSを別に追加したので、別ドメインの別keyで試せると思います。 
早速覗いて見たところ、以外に簡単な内容だったのでどうにか、追加できました。

変更は

var maps_google_co_jp_maps_ms = url.match(/^http:\/\/maps\.google\.co\.jp\/maps\/ms\?(.+)/);

上記の一行を増やしました。

if ( maps_google_co_jp_maps_ms || maps_google_co_jp_maps || maps_google_co_jp)

上記の先頭に『maps_google_co_jp_maps_ms || 』を増やしました。

これで3パターン変換がうまく動作するようになったようです。
zeroichiさん、kit.tさんヒントをどうもありがとうございました!!

History

#1 Updated by Kousuke Ebihara over 10 years ago

  • 3.6 で発生するか set to Yes

#2 Updated by Kousuke Ebihara over 10 years ago

  • Project changed from OpenPNE3 Plugins to OpenPNE 3

#3 Updated by Chiharu Nakajima over 3 years ago

  • 3.6 で発生するか changed from Yes to No (いいえ)
  • 3.8 で発生するか changed from Unknown (未調査) to No (いいえ)

3.6発生せず
3.8発生せず

#4 Updated by kaoru n over 1 year ago

  • Target version set to OpenPNE 3.10.x

Also available in: Atom PDF