Project

General

Profile

Bug(バグ) #2011

Updated by Minoru Takai about 11 years ago

h3. 概要

PHP 5.2.3〜5.2.5 で openpne:install を実行すると、インストール開始時点でセグメンテーション違反となり、インストールできない。
<pre>
>> installer start clean install
セグメンテーション違反です
</pre>

同梱されているセットアップドキュメントを確認すると、動作の想定バージョンはPHP5.2.3以降とある
<pre>
OpenPNE3 は以下のようなサーバ環境で動作させることを想定しています。

Webサーバ
Apache
* mod_rewrite を使用可能
PHP
PHP5.2.3 以降
</pre>

"note-19":http://redmine.openpne.jp/issues/2011#note-19 で示されていますが、 PHP5.2.6 以降では、インストール時に問題は生じないようです。 確認したPHPのバージョンはPHP5.2.4 までで、どのバージョンからインストール可能かは確認してない。

h3. 確認バージョン

* stable-3.6.x ブランチ(beta8 以降で確認している)でかつ PHP5.2.3 - 5.2.5 の環境 OpenPNE3.6beta8~
* OpenPNE3.7.0-dev


OpenPNE-3.4.x では発生せず、 OpenPNE-3.7.0dev でも発生しない(特定の範囲のバージョンの ZendFramework で生じる問題で、それが OpenPNE-3.6.x である)。

詳細は "note-20":http://redmine.openpne.jp/issues/2011#note-20 を参照。
※ OpenPNE3.4 では発生せず

Back