プロジェクト

全般

プロフィール

Task(タスク) #4112

Youichi Kimura10ヶ月前に更新

2017/01 時点の 現状の OpenPNE3 は、全ての安定版および master ブランチにおいて PHP7 では動作しない状態となっている (#3879)

h4. 調査 (完了)

PHP7
当チケットでは、PHP7 への移行にあたって以下の調査を行う。

* OpenPNE3 が PHP7 で動かない原因
* OpenPNE3 を PHP7 で動かすためにはどのような修正が必要か (機能を削る必要があるか)

h4. 修正

* 最低動作環境を PHP 5.4 以上とする
* "PEAR 1.10.1":https://pear.php.net/package/PEAR/download/1.10.1 へのアップデート
* "LExpress/symfony1":https://github.com/LExpress/symfony1 への移行
* Net_UserAgent_Mobile をアップデート
** ただしパッケージとしては未リリースのため GitHub から直接ソースコードを取得する必要がある
** https://github.com/iteman/net-useragent-mobile

戻る